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1 Introduction

SunGlobe is a tool in SolarSoft (Freeland and Handy, 1998) for selecting pointing using a 3D
representation of the solar globe. It is designed primarily for the Solar Orbiter mission, but can be
used for other missions as well. In the current implementation of the software, images are read in
from the Helioviewer database. As needs arise, other image and data sources can be added in the
future. For example, “hairy ball” magnetic field extrapolations are currently incorporated into the
software.

For the full capabilities of SunGlobe to be realized, it should be used in conjunction with the
SunSPICE package in SolarSoft. This enables the software to read in the ephemeris information
for the spacecraft so that the Sun can be portrayed with the right orientation and perspective. If
the SunSPICE package has not already been installed, instructions for installing it can be found at

https://stereo-ssc.nascom.nasa.gov/sunspice.shtml

SunSPICE will be automatically loaded for instruments which depend on it, such as
STEREO/SECCHI, or it can be listed as one of the “instruments” in the environment variable
SSW_INSTR.

There are a few accommodations that have been made in the software to support the Solar
Orbiter mission before it has been launched. At present, it automatically loads a sample ephemeris
for Solar Orbiter, based on a nominal launch date in October 2018. There’s also a TEST_OFFSET

keyword which can be used to make the software act as if Solar Orbiter has already launched, as
explained in the following section.

2 Starting SunGlobe

The SunGlobe program can be invoked simply by typing sunglobe at the IDL prompt. This will
bring up display window and main controls, as shown in Figure 1. There are also several keywords
which can be passed to the program; the most important of these are explained below.

SPACECRAFT: By default, SunGlobe will be configured for the Solar Orbiter spacecraft. The
spacecraft keyword can be used to select a different spacecraft supported by the SunSPICE
package. For example,

IDL> sunglobe, spacecraft=’ahead’

would configure SunSPICE to instead view the Sun from the viewpoint of the STEREO
Ahead spacecraft. Another alternative is to enter



Figure 1: SunGlobe display window and main controls.
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IDL> sunglobe, spacecraft=’earth’

for observations made from a ground observatory, or near Earth1 orbit (e.g. SDO). There
are also some menu items which will change depending on the value of the SPACECRAFT
keyword.

TEST OFFSET: Setting the keyword test_offset to an integer value n tells the program to
add n years to the date when accessing the spacecraft ephemeris. For example, if the date is
18-Nov-2016, and the program is called with

IDL> sunspice, test_offset=5

then the ephemeris data from the same date five years in the future, i.e. 18-Nov-2021, will
be used when calculating the spacecraft position, putting it within the valid range of the
pre-launch sample ephemeris file.

MAXIMAGES: Specifies the maximum number of images which can be read into the program.
The default is 10.

3 Tool layout and main controls

The layout of the SunGlobe program is shown in Figure 1. The widget tool is organized into four
sections. In the center is the image display window, which at the start of the program is blank
except for a heliographic grid. Along the top are pull-down menus which perform various actions.
The main widget controls are arranged in a column along the left side. Along the right side is an
area for the individual images. This starts out blank, and is filled in as images are read in (see
Figure 5).

The cursor can be used interactively within the display window in one of three ways, depending
on which checkbox is selected along the left side. Figure 2 zooms in on the three controls for the
three different cursor functions.

The program starts with the “Orientation” controls selected. This allows the user to use the
cursor to interactively control the orientation of the three-dimensional solar globe. The observer’s
viewpoint in Carrington heliographic longitude and latitude is displayed, along with the roll angle,
all in degrees. One can also control the orientation by typing into these boxes and pressing the
return key. Another field within this control section displays the solar distance in astronomical
units from which the Sun is observed. Changing this alters the perspective.

Selecting the “Ephemeris” checkbox changes the image orientation and observing distance based
on the observation date. This can be overridden by selecting “Lock orientation” in the Orientation
control section. Controls are also provided for changing the observation date and time; when these
are changed, the orientation and distance are updated accordingly, along with applying differential
solar rotation to all images which have been read in.

With “Ephemeris” selected, the cursor controls the spacecraft pointing. The Options pull-down
menu provides the opportunity to overplot the spacecraft boresight or the fields of view of several
of the Solar Orbiter instruments, which can then be controlled by the cursor. Figure 3 shows the
field-of-view of the SPICE instrument overplotted on a zoomed-in section of the Sun.

1This special case can be abbreviated to “sunglobe,/earth”.
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Figure 2: Controls which determine cursor function.

Figure 3: SPICE field-of-view overplotted on the solar image.
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Figure 4: Helioviewer image selection menu.

By default, the pointing coordinates displayed in the Ephemeris section are relative to the
roll angle with which the images are displayed. In other words, these pointing values are offsets
from Sun center along the spacecraft y and z axes. The HPC button will convert these into true
helioprojective-cartesian coordinates which are independent of spacecraft roll.

Selecting “Image center” allows the user to interactive move the image left-right and up-down
with the cursor. This is particularly useful when combined with the zoom in and out buttons just
below this section.

4 Reading images

Selecting “Read in Helioviewer image” from the “File” pull-down menu brings up a menu (Figure 4)
for selecting images from the Helioviewer database. First one selects the observatory, e.g. “SDO”.
Once that has been selected, one can select the associated instrument, e.g. “AIA”. Finally, one
can select the measurement, e.g. “193”. In cases where there’s only one choice, the program will
automatically advance to the next step.

Once the measurement has been selected, the helioviewer database will be searched, and the
closest date to the target date will be displayed, along with the difference in days between the two
dates. It’s also possible to change the target date and time for the image selection separately from
the date for the planned observation. One way this can be useful is to read in earlier images to fill
in parts of the Sun which are otherwise not covered. For example, if one read in both a recent AIA
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Figure 5: Result of reading in two images.

image along with one from two weeks earlier, most of the Sun would be covered.

Figure 5 shows the result of reading in two images, one from SDO/AIA, and the other from
STEREO-A/SECCHI. Once images have been read in, some additional controls become active.
Thumbnails of the read-in images appear along the right side of the tool. Each thumbnail includes
a check box which allows that image to be selected, and controls for the selected image are on the
lower left of the tool. Figure 6 zooms in on these regions. The image control region starts with
text boxes showing the identifier and date/time of the selected image. Below these, the “Move
up/down” buttons can be used to change the order of the images, i.e. which images are overlaid
on which. A slidebar can be used to change the image opacity, or the textbox can be used to enter
in a specific value. Finally, images can be discarded from the tool.

5 Other capabilities

5.1 PFSS magnetic field model

Selecting “Read in PFSS magnetic field” from the “File” pull-down menu allows one to read in
a Potential Field Source Surface magnetic field extrapolation model consistent with the selected
observation date (Figure 7). Differential rotation is applied in a rather simplistic fashion to this
model to ensure that the field lines match up with the solar features, so if the observation date is
changed considerably, it may be best to reingest the PFSS model. Selecting “PFSS mangetic field
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Figure 6: Image controls.

on/off” under the “Options” pull-down menu controls whether or not the model is visible.

5.2 Image save and restore

The options “Save images” and “Restore images” under the “File” pull-down menu allow the
current set of images to be saved into a data file, and then restored. The data are stored in
files with the extension “.geny”, e.g. “sunglobe.geny”. This option is recommended mainly for
temporary storage, since more up-to-date images become available with the passage of time.

5.3 Actions

The “Actions” pull-down menu allows one to reset a number of the tool parameter back to their
initial values, such as image roll angle or zoom factor.

5.4 Fields-of-view

The configure pull-down menu allows one to configure the (sub-disk) fields-of-view of the SPICE,
EUI, and PHI instruments. If the SPACECRAFT (or /EARTH) keyword is used to choose a
different mission, then a generic rectangular field-of-view can be configured instead. The individual
fields-of-view can be turned on or off through the “Options” pull-down menu.
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Figure 7: Potential Field Source Surface magnetic field extrapolation overplotted on the solar
images.
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Figure 8: Demonstration of calling SunGlobe from another program.

5.5 Orbit trace

The “Orbit trace on/off’ entry under the “Options” pull-down menu allows one to display a tracing
of the sub-orbital point on the solar surface as a function of time. Timesteps in the past (relative to
the target date) are shown as crosses (×), while those in the future are shown as diamonds (�). Both
symbols on top of each other mark the target time. “Configure orbit trace” under the “Configure”
pull-down menu allows one to define the number of time steps, and difference in time between them.

6 Interacting with another program

It is intended that SunGlobe be capable of interacting with other programs. The routine
sunglobe_demo.pro is a simple demonstration of the present capabilities of SunGlobe in this
regard. Currently, SunGlobe supports receiving date/time values from the calling program, and
sending back the spacecraft x and y pointing values. Other capabilities, such as instrument field-
of-view parameters, are anticipated to be added. Specific information about the events which can
be sent to SunGlobe, and the events which can be sent back from SunGlobe, are described in the
information header of the routine sunglobe_event.pro.

The first step in communicating between SunGlobe and another program is for that program to
call SunGlobe. There are several keywords in this call which make it possible for the two programs
to pass information back and forth:

GROUP LEADER: The widget ID of the group leader calling SunGlobe.

SENDBASE: Returns a widget ID in the SunGlobe program that events can be sent to.

RETURNID: The widget ID in the group leader that SunGlobe can send events to. This should
be the ID of a widget that does not otherwise take events, and whose UVALUE can be
overridden. The routine sunglobe_demo uses one of its widget subbases for this purpose.

In sunglobe_demo.pro this is done through the command

sunglobe, target_date, group_leader=event.top, $
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sendbase=sunglobe_base, returnid=sstate.wscpoint, $

test_offset=sstate.test_offset

The demonstration program sunglobe_demo.pro has controls for the observation date and time.
When these are changed, the new target date/time is sent to SunGlobe via the following code:

send_event = {id: 0L, top: 0L, handler: 0L, target_date: target_date}

widget_control, sstate.sunglobe_base, send_event=send_event, $

set_uvalue=’EVENT_TARGET_DATE’

where sstate.sunglobe_base is the value returned via the SENDBASE keyword in the previous
call to sunglobe.

Correspondingly, the SunGlobe can send pointing values back to the calling routine with the
“Send pointing values” button in the Ephemeris section of the controls on the left side of the tool.
This will send an event to the calling routine with a UVALUE of SUNGLOBE_POINTING, and with
the following tags in the event structure:

XSC: Spacecraft x pointing in arc seconds

YSC: Spacecraft y pointing in arc seconds

ROLL: Spacecraft roll angle in degrees for which the pointing values are valid. If roll-insensitive
HPC coordinates are desired instead, these can be calculated as follows:

roll = roll * !dpi / 180.d0

croll = cos(roll)

sroll = sin(roll)

xhpc = xsc * croll + ysc * sroll

yhpc = -xsc * sroll + ysc * croll

TARGET DATE: The target date for which the pointing values are valid. It’s recommended in
this scenario to use the calling program to control the target date, and to pass this on to
SunGlobe, rather than using the internal controls within SunGlobe to change the target date.
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